Back to overview
Degraded
Roblox Gamepasses Bug
May 3, 2026 at 3:00pm UTC
Affected services
Robux Payment Gateway
Resolved
May 5, 2026 at 5:09am UTC
Roblox has fixed the issue
Affected services
Updated
May 3, 2026 at 3:58pm UTC
We have notified Roblox about this issue
Affected services
Created
May 3, 2026 at 3:00pm UTC
Bug Detected at Roblox on our side
Affected services